import Foundation
let pattern = #"PAccountRegistered1"\s*:\s*"([0-9])""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"response":"success", "body":{"vendor_fullname":"Avaya Inc.","P35":"","PServer1":"10.2.0.100","PAccountRegistered1":"1","PBackupServer1":"10.2.0.50","PAccountBackupRegistered1":"0"}}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)