package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\?*[a-zA-Z\d]){2}[a-zA-Z\d?]*\*?$`)
var str = `abcd
?bcd
ab??
ab*
ab?*
??cd
a?????b????*
ab cd
*ab
???
ab? cd
ab ?d
ab *
a ? b
abcd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}