import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\?*[a-zA-Z\\d]){2}[a-zA-Z\\d?]*\\*?$";
final String string = "abcd\n"
+ "?bcd\n"
+ "ab??\n"
+ "ab*\n"
+ "ab?*\n"
+ "??cd\n"
+ "a?????b????*\n"
+ "ab cd\n"
+ "*ab\n"
+ "???\n"
+ "ab? cd\n"
+ "ab ?d\n"
+ "ab *\n"
+ "a ? b\n"
+ " abcd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}