re = /^(?:\?*[a-zA-Z\d]){2}[a-zA-Z\d?]*\*?$/m
str = 'abcd
?bcd
ab??
ab*
ab?*
??cd
a?????b????*
ab cd
*ab
???
ab? cd
ab ?d
ab *
a ? b
abcd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end