const regex = /^(?:\?*[a-zA-Z\d]){2}[a-zA-Z\d?]*\*?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\?*[a-zA-Z\\d]){2}[a-zA-Z\\d?]*\\*?$', 'gm')
const str = `abcd
?bcd
ab??
ab*
ab?*
??cd
a?????b????*
ab cd
*ab
???
ab? cd
ab ?d
ab *
a ? b
abcd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}