using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:d'accord|Réponse) (.*) Demande";
string input = @"d'accord De Massarte Marcel Demande
Réponse de Jean Jaques De La Martinière Demande
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}