re = /(?:d'accord|Réponse) (.*) Demande/m
str = 'd\'accord De Massarte Marcel Demande
Réponse de Jean Jaques De La Martinière Demande
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end