package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:d'accord|Réponse) (.*) Demande`)
var str = `d'accord De Massarte Marcel Demande
Réponse de Jean Jaques De La Martinière Demande
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}