$re = '/(?:d\'accord|Réponse) (.*) Demande/m';
$str = 'd\'accord De Massarte Marcel Demande
Réponse de Jean Jaques De La Martinière Demande
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);