const regex = /(?:d'accord|Réponse) (.*) Demande/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:d\'accord|Réponse) (.*) Demande', 'gm')
const str = `d'accord De Massarte Marcel Demande
Réponse de Jean Jaques De La Martinière Demande
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}