#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.+\/|\/{2,}"
Local $sString = "../../.././../../././../files/New folder" & @CRLF & _
"../../.././../../././../files/New folder/../../././../.././" & @CRLF & _
"./files/New folder/" & @CRLF & _
"///../..///files/New folder///../"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)