re = /\.+\/|\/{2,}/m
str = '../../.././../../././../files/New folder
../../.././../../././../files/New folder/../../././../.././
./files/New folder/
///../..///files/New folder///../'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result