import Foundation
let pattern = #"\.+\/|\/{2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
../../.././../../././../files/New folder
../../.././../../././../files/New folder/../../././../.././
./files/New folder/
///../..///files/New folder///../
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)