$re = '/\.+\/|\/{2,}/m';
$str = '../../.././../../././../files/New folder
../../.././../../././../files/New folder/../../././../.././
./files/New folder/
///../..///files/New folder///../';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;