#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([0-9]{1,2}\.[0-9]{1,2}\.[0-9]{4}\s*)(05:00)(?=.*\s+^\1\2)"
Local $sString = "31.03.2024 01:00 1.002" & @CRLF & _
"31.03.2024 03:00 2.003" & @CRLF & _
"31.03.2024 05:00 3.007" & @CRLF & _
"31.03.2024 05:00 4.985" & @CRLF & _
"31.03.2024 06:00 2.987"
Local $sSubst = "${1}04:00"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)