import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^([0-9]{1,2}\\.[0-9]{1,2}\\.[0-9]{4}\\s*)(05:00)(?=.*\\s+^\\1\\2)";
final String string = "31.03.2024 01:00 1.002\n"
+ "31.03.2024 03:00 2.003\n"
+ "31.03.2024 05:00 3.007\n"
+ "31.03.2024 05:00 4.985\n"
+ "31.03.2024 06:00 2.987";
final String subst = "${1}04:00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}