const regex = new RegExp('(?m)^([0-9]{1,2}\\.[0-9]{1,2}\\.[0-9]{4}\\s*)(05:00)(?=.*\\s+^\\1\\2)', 'g')
const str = `31.03.2024 01:00 1.002
31.03.2024 03:00 2.003
31.03.2024 05:00 3.007
31.03.2024 05:00 4.985
31.03.2024 06:00 2.987`;
const subst = `${1}04:00`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);