#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\S+\s+up\s+(?<uptime>(?:\S+\s+days,\s+\d+:\d+|\S+\s+min)|\d+:\d+)"
Local $sString = " 16:37:50 up 18 days, 19:59, load average: 0.23, 0.26, 0.29" & @CRLF & _
" 11:12:08 up 899 days, 20:35, 2 users, load average: 0.28, 0.29, 0.25" & @CRLF & _
" 15:19:17 up 22:45, load average: 0.18, 0.31, 0.36" & @CRLF & _
" 11:11:11 up 12:55, 2 users, load averages: 0.00, 0.01, 0.06" & @CRLF & _
" 11:11:11 up 55 min, 2 users, load averages: 0.00, 0.01, 0.06" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")