import re
regex = re.compile(r"^\s*\S+\s+up\s+(?<uptime>(?:\S+\s+days,\s+\d+:\d+|\S+\s+min)|\d+:\d+)", flags=re.MULTILINE)
test_str = (" 16:37:50 up 18 days, 19:59, load average: 0.23, 0.26, 0.29\n"
" 11:12:08 up 899 days, 20:35, 2 users, load average: 0.28, 0.29, 0.25\n"
" 15:19:17 up 22:45, load average: 0.18, 0.31, 0.36\n"
" 11:11:11 up 12:55, 2 users, load averages: 0.00, 0.01, 0.06\n"
" 11:11:11 up 55 min, 2 users, load averages: 0.00, 0.01, 0.06\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")