use strict;
my $str = ' 16:37:50 up 18 days, 19:59, load average: 0.23, 0.26, 0.29
11:12:08 up 899 days, 20:35, 2 users, load average: 0.28, 0.29, 0.25
15:19:17 up 22:45, load average: 0.18, 0.31, 0.36
11:11:11 up 12:55, 2 users, load averages: 0.00, 0.01, 0.06
11:11:11 up 55 min, 2 users, load averages: 0.00, 0.01, 0.06
';
my $regex = qr/^\s*\S+\s+up\s+(?<uptime>(?:\S+\s+days,\s+\d+:\d+|\S+\s+min)|\d+:\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}