import Foundation
let pattern = #"^\s*\S+\s+up\s+(?<uptime>(?:\S+\s+days,\s+\d+:\d+|\S+\s+min)|\d+:\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
16:37:50 up 18 days, 19:59, load average: 0.23, 0.26, 0.29
11:12:08 up 899 days, 20:35, 2 users, load average: 0.28, 0.29, 0.25
15:19:17 up 22:45, load average: 0.18, 0.31, 0.36
11:11:11 up 12:55, 2 users, load averages: 0.00, 0.01, 0.06
11:11:11 up 55 min, 2 users, load averages: 0.00, 0.01, 0.06
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)