using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=\""(['/clothing/Skirt/']*)\"">(.*)<\/a>";
string input = @"<a href=""/clothing/jacket/"">Jacket</a>
<a href=""/clothing/Socks/"">Socks</a>
<a href=""/clothing/Shoes/"">Shoes</a>
<a href=""/clothing/Skirt/"">Skirt</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}