re = /<a href=\"(['\/clothing\/Skirt\/']*)\">(.*)<\/a>/
str = '<a href="/clothing/jacket/">Jacket</a>
<a href="/clothing/Socks/">Socks</a>
<a href="/clothing/Shoes/">Shoes</a>
<a href="/clothing/Skirt/">Skirt</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end