package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a href=\"(['/clothing/Skirt/']*)\">(.*)<\/a>`)
var str = `<a href="/clothing/jacket/">Jacket</a>
<a href="/clothing/Socks/">Socks</a>
<a href="/clothing/Shoes/">Shoes</a>
<a href="/clothing/Skirt/">Skirt</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}