// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a href=\"(['/clothing/Skirt/']*)\">(.*)<\/a>"#).unwrap();
let string = "<a href=\"/clothing/jacket/\">Jacket</a>
<a href=\"/clothing/Socks/\">Socks</a>
<a href=\"/clothing/Shoes/\">Shoes</a>
<a href=\"/clothing/Skirt/\">Skirt</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}