import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href=\\\"(['/clothing/Skirt/']*)\\\">(.*)<\\/a>";
final String string = "<a href=\"/clothing/jacket/\">Jacket</a>\n"
+ "<a href=\"/clothing/Socks/\">Socks</a>\n"
+ "<a href=\"/clothing/Shoes/\">Shoes</a>\n"
+ "<a href=\"/clothing/Skirt/\">Skirt</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}