# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<.*Page #.*$)/$1\nfoo\nbar\n/gm;t' <<< " <text:p text:style-name=\"P27\"><text:span text:style-name=\"T20\">Page #</text:span><text:span text:style-name=\"T19\"><text:tab/></text:span><text:span text:style-name=\"T20\">Content</text:span></text:p>
<text:p text:style-name=\"P27\"><text:span text:style-name=\"T20\">Page #</text:span><text:span text:style-name=\"T19\"><text:tab/></text:span><text:span text:style-name=\"T20\">Content</text:span></text:p>
<text:p>some other text</text:p>
<text:p text:style-name=\"P27\"><text:span text:style-name=\"T20\">Page #</text:span><text:span text:style-name=\"T19\"><text:tab/></text:span><text:span text:style-name=\"T20\">Content</text:span></text:p>"