// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<.*Page #.*$)").unwrap();
let string = " <text:p text:style-name=\"P27\"><text:span text:style-name=\"T20\">Page #</text:span><text:span text:style-name=\"T19\"><text:tab/></text:span><text:span text:style-name=\"T20\">Content</text:span></text:p>
<text:p text:style-name=\"P27\"><text:span text:style-name=\"T20\">Page #</text:span><text:span text:style-name=\"T19\"><text:tab/></text:span><text:span text:style-name=\"T20\">Content</text:span></text:p>
<text:p>some other text</text:p>
<text:p text:style-name=\"P27\"><text:span text:style-name=\"T20\">Page #</text:span><text:span text:style-name=\"T19\"><text:tab/></text:span><text:span text:style-name=\"T20\">Content</text:span></text:p>";
let substitution = "$1\\nfoo\\nbar\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}