use strict;
my $str = ' <text:p text:style-name="P27"><text:span text:style-name="T20">Page #</text:span><text:span text:style-name="T19"><text:tab/></text:span><text:span text:style-name="T20">Content</text:span></text:p>
<text:p text:style-name="P27"><text:span text:style-name="T20">Page #</text:span><text:span text:style-name="T19"><text:tab/></text:span><text:span text:style-name="T20">Content</text:span></text:p>
<text:p>some other text</text:p>
<text:p text:style-name="P27"><text:span text:style-name="T20">Page #</text:span><text:span text:style-name="T19"><text:tab/></text:span><text:span text:style-name="T20">Content</text:span></text:p>';
my $regex = qr/(<.*Page #.*$)/mp;
my $subst = '$1\\nfoo\\nbar\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";