using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<.*Page #.*$)";
string substitution = @"$1\nfoo\nbar\n";
string input = @" <text:p text:style-name=""P27""><text:span text:style-name=""T20"">Page #</text:span><text:span text:style-name=""T19""><text:tab/></text:span><text:span text:style-name=""T20"">Content</text:span></text:p>
<text:p text:style-name=""P27""><text:span text:style-name=""T20"">Page #</text:span><text:span text:style-name=""T19""><text:tab/></text:span><text:span text:style-name=""T20"">Content</text:span></text:p>
<text:p>some other text</text:p>
<text:p text:style-name=""P27""><text:span text:style-name=""T20"">Page #</text:span><text:span text:style-name=""T19""><text:tab/></text:span><text:span text:style-name=""T20"">Content</text:span></text:p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}