package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<.*Page #.*$)`)
var str = ` <text:p text:style-name="P27"><text:span text:style-name="T20">Page #</text:span><text:span text:style-name="T19"><text:tab/></text:span><text:span text:style-name="T20">Content</text:span></text:p>
<text:p text:style-name="P27"><text:span text:style-name="T20">Page #</text:span><text:span text:style-name="T19"><text:tab/></text:span><text:span text:style-name="T20">Content</text:span></text:p>
<text:p>some other text</text:p>
<text:p text:style-name="P27"><text:span text:style-name="T20">Page #</text:span><text:span text:style-name="T19"><text:tab/></text:span><text:span text:style-name="T20">Content</text:span></text:p>`
var substitution = "$1\nfoo\nbar\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}