#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([\w-]{2,50})+([\@]){1}+([\w-]{2,50})+([.]){1}([\w-]{2,10}))$"
Local $sString = "testtest@gmail.com" & @CRLF & _
"testTest@yahoo.fr" & @CRLF & _
"123@yahoo.fr" & @CRLF & _
"_-@test.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")