$re = '/^(([\w-]{2,50})+([\@]){1}+([\w-]{2,50})+([.]){1}([\w-]{2,10}))$/m';
$str = 'testtest@gmail.com
testTest@yahoo.fr
123@yahoo.fr
_-@test.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);