import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([\\w-]{2,50})+([\\@]){1}+([\\w-]{2,50})+([.]){1}([\\w-]{2,10}))$";
final String string = "testtest@gmail.com\n"
+ "testTest@yahoo.fr\n"
+ "123@yahoo.fr\n"
+ "_-@test.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}