#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bgoat\s*milk\b(*SKIP)(*FAIL)|\b(?:eggs?|milk)\b"
Local $sString = "milk, goatmilk, goat milk, cow milk, watch out for ( milk, eggs), egg, cornstarch" & @CRLF & _
"milk. goatmilk. goat milk. cow milk. watch out for ( milk, eggs). egg. cornstarch" & @CRLF & _
"milk goatmilk goat milk cow milk watch out for ( milk, eggs). egg cornstarch"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")