import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bgoat\\s*milk\\b(*SKIP)(*FAIL)|\\b(?:eggs?|milk)\\b";
final String string = "milk, goatmilk, goat milk, cow milk, watch out for ( milk, eggs), egg, cornstarch\n"
+ "milk. goatmilk. goat milk. cow milk. watch out for ( milk, eggs). egg. cornstarch\n"
+ "milk goatmilk goat milk cow milk watch out for ( milk, eggs). egg cornstarch";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}