package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bgoat\s*milk\b(*SKIP)(*FAIL)|\b(?:eggs?|milk)\b`)
var str = `milk, goatmilk, goat milk, cow milk, watch out for ( milk, eggs), egg, cornstarch
milk. goatmilk. goat milk. cow milk. watch out for ( milk, eggs). egg. cornstarch
milk goatmilk goat milk cow milk watch out for ( milk, eggs). egg cornstarch`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}