re = /\bgoat\s*milk\b(*SKIP)(*FAIL)|\b(?:eggs?|milk)\b/
str = 'milk, goatmilk, goat milk, cow milk, watch out for ( milk, eggs), egg, cornstarch
milk. goatmilk. goat milk. cow milk. watch out for ( milk, eggs). egg. cornstarch
milk goatmilk goat milk cow milk watch out for ( milk, eggs). egg cornstarch'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end