const regex = /\bgoat\s*milk\b(*SKIP)(*FAIL)|\b(?:eggs?|milk)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bgoat\\s*milk\\b(*SKIP)(*FAIL)|\\b(?:eggs?|milk)\\b', 'g')
const str = `milk, goatmilk, goat milk, cow milk, watch out for ( milk, eggs), egg, cornstarch
milk. goatmilk. goat milk. cow milk. watch out for ( milk, eggs). egg. cornstarch
milk goatmilk goat milk cow milk watch out for ( milk, eggs). egg cornstarch`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}