#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?!.*\bnever\b.{,20}\bwater\b).*\bwater\b"
Local $sString = "water" & @CRLF & _
"I have water" & @CRLF & _
"I never have water" & @CRLF & _
"Where is the water" & @CRLF & _
"I never have food or water" & @CRLF & _
"I never have food but I always have water" & @CRLF & _
"I never have food or chips. I like to walk. I have water"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")