re = /(?i)^(?!.*\bnever\b.{,20}\bwater\b).*\bwater\b/m
str = 'water
I have water
I never have water
Where is the water
I never have food or water
I never have food but I always have water
I never have food or chips. I like to walk. I have water'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end