import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?!.*\\bnever\\b.\\{,20\\}\\bwater\\b).*\\bwater\\b";
final String string = "water\n"
+ "I have water\n"
+ "I never have water\n"
+ "Where is the water\n"
+ "I never have food or water\n"
+ "I never have food but I always have water\n"
+ "I never have food or chips. I like to walk. I have water";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}