use strict;
my $str = 'water
I have water
I never have water
Where is the water
I never have food or water
I never have food but I always have water
I never have food or chips. I like to walk. I have water';
my $regex = qr/(?i)^(?!.*\bnever\b.{,20}\bwater\b).*\bwater\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}