using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(?!.*\bnever\b.{,20}\bwater\b).*\bwater\b";
string input = @"water
I have water
I never have water
Where is the water
I never have food or water
I never have food but I always have water
I never have food or chips. I like to walk. I have water";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}