#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*[a-zA-Z]+([\-\s']?[a-zA-Z]+)*\s*,\s*[a-zA-Z\s]+([\-\s']?[a-zA-Z]+)*\s*$"
Local $sString = "my-name, is bryan" & @CRLF & _
"hello, world" & @CRLF & _
"what about, me" & @CRLF & _
"Virtuous Blower, Jr" & @CRLF & _
"Mr Happy Sack, Yep" & @CRLF & _
"d'Mello, Anton" & @CRLF & _
"Mysterys" & @CRLF & _
"D'Art, Loui"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")