const regex = /^\s*[a-zA-Z]+([\-\s']?[a-zA-Z]+)*\s*,\s*[a-zA-Z\s]+([\-\s']?[a-zA-Z]+)*\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*[a-zA-Z]+([\\-\\s\']?[a-zA-Z]+)*\\s*,\\s*[a-zA-Z\\s]+([\\-\\s\']?[a-zA-Z]+)*\\s*$', 'gm')
const str = `my-name, is bryan
hello, world
what about, me
Virtuous Blower, Jr
Mr Happy Sack, Yep
d'Mello, Anton
Mysterys
D'Art, Loui`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}