$re = '/^\s*[a-zA-Z]+([\-\s\']?[a-zA-Z]+)*\s*,\s*[a-zA-Z\s]+([\-\s\']?[a-zA-Z]+)*\s*$/m';
$str = 'my-name, is bryan
hello, world
what about, me
Virtuous Blower, Jr
Mr Happy Sack, Yep
d\'Mello, Anton
Mysterys
D\'Art, Loui';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);