// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*[a-zA-Z]+([\-\s']?[a-zA-Z]+)*\s*,\s*[a-zA-Z\s]+([\-\s']?[a-zA-Z]+)*\s*$").unwrap();
let string = "my-name, is bryan
hello, world
what about, me
Virtuous Blower, Jr
Mr Happy Sack, Yep
d'Mello, Anton
Mysterys
D'Art, Loui";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}