using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*[a-zA-Z]+([\-\s']?[a-zA-Z]+)*\s*,\s*[a-zA-Z\s]+([\-\s']?[a-zA-Z]+)*\s*$";
string input = @"my-name, is bryan
hello, world
what about, me
Virtuous Blower, Jr
Mr Happy Sack, Yep
d'Mello, Anton
Mysterys
D'Art, Loui";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}