# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[^A-Z0-9]*|[A-Z0-9]*)([A-Z0-9][^A-Z]+|$)/ ${1} $2/gm;t' <<< "thisString
rssTitle
RSSTitle
weLikeFOSS"